A hidden horror

An Asus Zenbook UX21 that I sometimes maintain has has had one too many trips over the power chord and the power jack has become awfully flaky, so much so that it’s now broken to the point of being unusable. Doubly unfortunate is that the PSU died and the 3rd party one doesn’t have the light that tells you when it’s charging, and the battery is quite bad now so it’s easy for it to run out of power and then it’s really hard to tell if it’s charging or just sitting there.

On the whole, it’s been an excellent laptop but is beginning to feel its age, which makes me a lot less nervous about opening it up to see if it can easily be fixed. The only other non-abuse failing is that some of the screws fell out of the case. This seems a common complaint among Zenbook owners.

Due to the generally excellent build quality it was easy to get apart, just popping off the remaining case screws. the back came off easily:

img_20180107_200430.jpg

The laptop is mostly battery!

The motherboard is really tiny and remarkably thin, so care is needed to not flex it. The SSD is upgradable which I didn’t realise and uses a proprietary connector for which adapters exist, fortunately. The heatsinking is decent with a rather dust-clogged fan on the end of a decent heatpipe.

Once inside, it came apart easily. On to the offending part, the power jack. Here it is:

IMG_20180107_202512

see anything wrong? Weirdly it looks just fine. The last one I replaced on a laptop was smashed all to pieces. That’s good because it’s an oddball part and I’m gland I don’t need to find a replacement. Part of that is due to the barrel coming in through a relatively tight fitting hole in a relatively thick metal case, so there’s quite a lot of mechanical rigidity there.

But look closer:

img_20180107_202516.jpg

see the bit at the top where the pin solders to the board? That joint is well dodgy! Turns out that the copper ring around the pin is really thin and once I melted the solder, it turned out that the pin isn’t even long enough, so the end is barely flush with the top of the board. Those two combine to make a really fragile connection.

The fix was easy, just adding some flux, removing the old solder and replacing it with new, quality (leaded) solder made it work perfectly.

So now it works again, and a replacement battery is on the way so it should have a good few years more left in it.

But especially given the overall build that was a remarkably poor job on a part often subject to high stresses.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s